jQuery: versões, e o conflito entre eles





jQuery: sus versiones y el conflicto entre ellas





Muchos conocen y usan jQuery, la librería de efectos de mayor uso por los fantásticos plugins que ofrece. Quienes lo usan saben que no es compatible con algunas librerías de efectos pero tambiéncómo solucionar esa incompatibilidad.
Sin embargo, algunas veces ponemos dos o más gadgets que usan jQuery y las cosas no resultan tan bien cómo esperábamos. La razón en la mayoría de los casos es que cada vez que ponemos un gadget o un efecto agregamos jQuery de nuevo, así que la plantilla se va llenando de varias versiones de jQuery y aquí es donde se genera el conflicto y las cosas no funcionan.

¿Qué hacer? Primero que nada procurar tener siempre la última versión de jQuery, al día de hoy 5 de octubre de 2011 la versión más actual es la 1.6.4, pero para que puedas estar al tanto de cuál es la última versión visita el catálogo de librerías de Google API, ahí verás la última versión estable de jQuery y la URL del script.

¿Cómo lo ponemos? Siempre antes de </head> o después de <head> una línea así:
<script src='https://ajax.googleapis.com/ajax/libs/jquery/1.6.4/jquery.min.js' type='text/javascript'/>

Lo segundo es, ya puesta la última versión de jQuery procedemos a buscar las versiones antiguas y eliminarlas una por una. Para hacerlo más fácil usa las teclas CTRL + F y usa el término jquery/ para encontrarlo. Deberá estar como la línea anterior aunque la URL no sea exactamente igual, esto es porque puede estar alojado en otro servidor.
Una vez que localices una versión anterior, por ejemplo la 2.1.0, elimínala, guarda los cambios y revisa que todo lo que requiera jQuery siga funcionando, si todo está bien regresa a buscar más versiones antiguas (o repetidas) y elimínalas.

Tenemos que hacerlo una por una y cada vez que lo hagamos revisar que todo funcione, esto es porque algunos plugins funcionan sólo con determinada versión de jQuery, así que es probable que algún gadget o efecto pueda funcionar unicamente con una versión antigua. En esos casos lo ideal es buscar un gadget similar que sí funcione con la última versión para evitar depender de un script anticuado.

Habiendo eliminado las versiones repetidas, o antiguas de jQuery tendrás un blog que no sólo cargará un poco más rápido sino que evitarás conflictos entre las diferentes versiones de jQuery.
Así que cada vez que uses algo que necesita jQuery, no necesitas agregar el script de nuevo, si ya lo tienes continua con los demás pasos, y sino funciona entones es probable que ese "algo" que has agregado sólo funcione con una versión en particular.


fonte e créditos:
ciudadblogger.






traduzido                                                           





jQuery: versões, e o conflito entre eles

Muitos conhecem e utilizam jQuery , os efeitos do uso da biblioteca aumentou oferta de plugins fantásticos. Que a usam sabem que não é compatível com algumas bibliotecas, mas também efeitoscomo corrigir essa incompatibilidade .
No entanto, às vezes colocamos dois ou mais aparelhos que usam jQuery e as coisas não são tão bons quanto o esperado. A razão na maioria dos casos é que cada vez que colocamos um gadget ou adicionar efeitos jQuery de novo, para que o modelo está sendo preenchido com várias versões do jQuery e este é o lugar onde o conflito é gerado e as coisas não funcionam.

O que fazer? Primeiro de tudo tentar ter sempre a última versão do jQuery , até à data 5 de outubro de 2011 a versão mais atual é 1.6.4, mas você pode estar ciente do que a versão mais recente visitar o catálogo da biblioteca API do Google , lá você vai ver a última versão estável do jQuery e do URL do script.

Como é que vamos? Sempre antes </ head> <head> ou depois de uma linha como esta:
<Script src = ' https://ajax.googleapis.com/ajax/libs/jquery/1.6.4/jquery.min.js "type =" text / javascript '/>

A segunda coisa é, você coloca a última versão do jQuery proceder para encontrar as versões antigas e apagar um por um. Para torná-lo mais fácil de usar o CTRL + F e usa o termo jquery /encontrá-lo. Linha deve ser como anteriormente, mas a URL não é exatamente o mesmo, isso é porque ele pode ser hospedado em outro servidor.
Depois de localizar uma versão anterior, 2.1.0, por exemplo, em seguida, removê-lo, salve as alterações e verificar que tudo o que requer jQuery ainda está trabalhando, se está tudo ok para olhar para trás em relação às versões mais velhas (ou repetido) e removê-los.

Temos que fazer um por um e cada vez que fazemos verificar se tudo funciona, é porque alguns plugins trabalhar apenas com versão específica do jQuery, por isso é provável que alguns gadget ou efeito pode funcionar apenas com uma versão mais antiga. Nesses casos, o ideal é encontrar um gadget similar que funciona com a versão mais recente para evitar confiar no script desatualizado.

Tendo eliminado o versões repetidas, ou antigo blog jQuery não só irá carregar um pouco mais rápido, mas vai evitar conflitos entre diferentes versões do jQuery.
Assim, cada vez que você usa algo que precisa jQuery, não há necessidade de adicionar o script novamente, se tiver de continuar com as outras etapas, e ele funciona, então é provável que "algo" que você adicionou apenas trabalhar com uma versão específica .


Postar um comentário

1 Comentários

  1. Olá minha querida amiga Edilene!!!
    Minha doce amiga, parabéns por mais essa bela dica, adorei saber!!!
    Minha amiga, que bom poder contar sempre com os seus ensinamentos, parabéns por estar sempre dividindo os seus conhecimentos com todos nós!!!
    Parabéns também pela excelente escolha!!!
    Tenha uma linda e abençoada noite, repleta de muita luz!!!
    Beijos e muita paz em seu caminho!!!

    ResponderExcluir

Mensagem do formulário de comentário: